CVE-2026-42271

BerriAI LiteLLM Command Injection Vulnerability — BerriAI / LiteLLM

Risk tier: Monitored

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Scoring

  • CVSS: 8.8 (HIGH, 3.1)
  • EPSS exploitation probability: Not yet available
  • EPSS percentile: Not yet available

CISA KEV status

  • Added to KEV: 2026-06-08
  • Remediation due date: 2026-06-22
  • Known ransomware campaign use: Unknown

Weakness types (CWE)

  • CWE-77
  • CWE-78
  • CWE-78

References

More HIGH-severity vulnerabilities · All exploited vulnerabilities