Description
A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
Scoring
- CVSS: 10 (CRITICAL, 3.1)
- EPSS exploitation probability: Not yet available
- EPSS percentile: Not yet available
CISA KEV status
- Added to KEV: 2026-10-14
- Remediation due date: 2026-10-17
- Known ransomware campaign use: Unknown
Weakness types (CWE)
- CWE-77
- CWE-78
References
- https://vuldb.com/cve/CVE-2026-105134
- https://vuldb.com/submit/942743
- https://vuldb.com/vuln/413351
- https://vuldb.com/vuln/413351/cti
- https://www.ahsay.com/en/company/announcements/patch-cve-105133-105134-update
- https://www.huntress.com/blog/ahsaycbs-flaws-exploit
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-105134
More from Ahsay
- CVE-2026-105133 — AhsayCBS
More CRITICAL-severity vulnerabilities · All exploited vulnerabilities