CVE-2025-54068

Laravel Livewire Code Injection Vulnerability — Laravel / Livewire

Risk tier: Monitored

Description

Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.

Scoring

  • CVSS: 9.8 (CRITICAL, 3.1)
  • EPSS exploitation probability: Not yet available
  • EPSS percentile: Not yet available

CISA KEV status

  • Added to KEV: 2026-03-20
  • Remediation due date: 2026-04-03
  • Known ransomware campaign use: Unknown

Weakness types (CWE)

  • CWE-94

References

More CRITICAL-severity vulnerabilities · All exploited vulnerabilities