CVE-2024-51567

CyberPanel Incorrect Default Permissions Vulnerability — CyberPersons / CyberPanel

Risk tier: Critical — known ransomware use

Description

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

Scoring

  • CVSS: 10 (CRITICAL, 3.1)
  • EPSS exploitation probability: Not yet available
  • EPSS percentile: Not yet available

CISA KEV status

  • Added to KEV: 2024-11-07
  • Remediation due date: 2024-11-28
  • Known ransomware campaign use: Known

Weakness types (CWE)

  • CWE-306
  • CWE-306

References

More CRITICAL-severity vulnerabilities · All exploited vulnerabilities